A World of Ice and Fire Forums
A Modification for Mount & Blade

News:

  • Welcome to the Forums for the A World of Ice and Fire Modification for Mount&Blade.

    Please register to view extra boards and access special features.
    Be sure to check back here often for all new updates and information.

  • Full Version v6.1

  • Patch v6.2

Author Topic: Modification Installation.  (Read 661 times)

0 Members and 1 Guest are viewing this topic.

Offline Produno

  • AWOIAF Mod Leader
  • Administrator
  • Lord Commander
  • *****
  • Posts: 2152
  • Reputation: 200
  • AWOIAF Lead Developer
    • View Profile
    • Twitter
  • Faction: The North
on: August 05, 2019, 10:27:23 AM
Here is a quick video explaining how to install the modification.











Installation information from @Riven

A: Here is how I went about it (beta 7, someone PM me with more updated instruction, I don't have a Mac):
1. I extracted the Beta 7 Final RAR file, kept it in my downloads folder. I used Unarchiver, but other software might also work, YMMV.
2. I extracted the hot fix 2.2 RAR file, also kept this in my downloads folder. Again, I used Unarchiver.
3. After I had both RAR files extracted and in separate folders, I then selected all (CMD+A) files inside the Hotfix 2.2 folder in Finder, and copied them (CMD+C).
4. Having copied the files in the hot fix 2.2 folder, I then opened the Beta 7 Final folder, and right clicked, choosing "paste XX items".
5. This next step turned out to be what solved the CTD problem for me, here is why:
When you choose to Paste the items into the folder, Finder will ask you what to do about files that already exist in the destination folder(beta 7 final). My mistake was that I chose "replace" and checked the box for "apply to all". This tells Finder to replace all duplicates, both files and folders, with the newest version from the hot fix 2.2 folder. But this actually causes Finder to delete other files inside any folders you choose to replace, i.e. the update actually causes Finder to delete files. And that is what causes the CTD when you try to load the mod; the files needed to load the mod are no longer there.
6. So, here is the solution, for me at least: when Finder asks you what to do with the very first duplicate file or folder, do not check the box that says "apply to all". Instead, review each duplicate file and folder(do not worry, it takes no time at all). Here is what you need to choose for files or folder, when Finder asks you:
For files: Choose "replace". Again, if the option is available, do not check the box that says "apply to all."
For folders: Choose "merge". Again, if the option is available, do not check the box that says "apply to all."

When you are done copying, open Steam, Select the AWOIAF Module and launch. When I followed the steps outlined above, I was very pleased to see the mod loading without any problems. As soon as you reach the in game menu screen, you will see Hotfix#2 in the mod title. And if you really need in game confirmation, start a new game...
« Last Edit: August 05, 2019, 10:51:04 AM by Produno »



Celsiat

  • Guest
Reply #1 on: July 20, 2020, 02:36:49 PM
I follow the same steps but the game continues to open for version 3.5




Offline Produno

  • AWOIAF Mod Leader
  • Administrator
  • Lord Commander
  • *****
  • Posts: 2152
  • Reputation: 200
  • AWOIAF Lead Developer
    • View Profile
    • Twitter
  • Faction: The North
Reply #2 on: July 26, 2020, 02:09:47 PM
I follow the same steps but the game continues to open for version 3.5

Where are you installing from Steam or ModDB?